All Classes and Interfaces
Class
Description
Provides mapping for (crypto) algorithms.
https://tools.ietf.org/html/rfc8446#section-6.2
"bad_certificate: A certificate was corrupt, contained signatures that did not verify correctly, etc."
https://tools.ietf.org/html/rfc8446#section-4.2.4
https://tools.ietf.org/html/rfc8446#section-6.2
"certificate_unknown: Some other (unspecified) issue arose in processing the certificate, rendering it unacceptable."
https://tools.ietf.org/html/rfc8446#section-4.4.3
"Certificate Verify
This message is used to provide explicit proof that an endpoint possesses the private key corresponding to its certificate.
https://datatracker.ietf.org/doc/html/rfc8446#section-4.1.2
TLS Pre-Shared Key Extension, ClientHello variant.
The TLS cookie extension.
https://tools.ietf.org/html/rfc8446#section-6.2
"decode_error: A message could not be decoded because some field was
out of the specified range or the length of the message was
incorrect.
https://tools.ietf.org/html/rfc8446#section-6.2
"decrypt_error: A handshake (not record layer) cryptographic
operation failed, including being unable to correctly verify a
signature or validate a Finished message or a PSK binder."
A hostname verifier that requires that the server name equals the CN part of the certificate's subject DN,
or matches one of the dnsName-type "Subject Alternative Name" entries of the certificate.
TLS Early Data Indication extension.
Implementation of the Elliptic Curve Diffie-Hellman Ephemeral (ECDHE) key exchange algorithm.
https://tools.ietf.org/html/rfc8446#section-4.3.1
https://tools.ietf.org/html/rfc8446#section-6.2
A TLS Extension.
Parses the block of extensions that a handshake message carries: the two-byte length field followed by the
sequence of extensions.
A functional interface for parsing (custom) TLS extensions from a byte stream.
https://datatracker.ietf.org/doc/html/rfc8446#section-4.4.4
https://tools.ietf.org/html/rfc8446#section-6.2
"handshake_failure: Receipt of a "handshake_failure" alert message
indicates that the sender was unable to negotiate an acceptable
set of security parameters given the options available."
https://datatracker.ietf.org/doc/html/rfc8446#section-4
https://datatracker.ietf.org/doc/html/rfc8446#section-4.1.4
"As discussed in Section 4.1.3, the HelloRetryRequest has the same format as a ServerHello message, and the
legacy_version, legacy_session_id_echo, cipher_suite, and legacy_compression_method fields have the same meaning.
Base for the RFC 10024 post-quantum/traditional hybrid key exchange
groups (X25519MLKEM768, SecP256r1MLKEM768, SecP384r1MLKEM1024).
Provides the RFC 10024 post-quantum/traditional hybrid key exchange groups.
https://tools.ietf.org/html/rfc8446#section-6.2
"illegal_parameter: A field in the handshake was incorrect or
inconsistent with other fields.
https://tools.ietf.org/html/rfc8446#section-6.2
"internal_error: An internal error unrelated to the peer or the
correctness of the protocol (such as a memory allocation failure)
makes it impossible to continue."
Creates the key exchange implementation for a given TLS named group.
The TLS "key_share" extension contains the endpoint's cryptographic parameters.
https://tools.ietf.org/html/rfc8446#section-6.2
"missing_extension: Sent by endpoints that receive a handshake
message not containing an extension that is mandatory to send for
the offered TLS version or other negotiated parameters."
ML-DSA-44, backing the mldsa44 TLS signature scheme.
ML-DSA-65, backing the mldsa65 TLS signature scheme.
ML-DSA-87, backing the mldsa87 TLS signature scheme.
ML-DSA (FIPS 204), the post-quantum signature scheme
underlying the mldsa44/mldsa65/mldsa87 TLS signature schemes.
Provides the ML-DSA (FIPS 204) post-quantum signature
schemes.
ML-KEM-1024, the pqc component of the SecP384r1MLKEM1024 hybrid group
(RFC 10024).
ML-KEM-768, the pqc component of the X25519MLKEM768 and
SecP256r1MLKEM768 hybrid groups (RFC 10024).
ML-KEM key exchange (FIPS 203), using the JDK's own KEM API
(javax.crypto.KEM).
https://tools.ietf.org/html/rfc8446#section-4.6.1
https://tools.ietf.org/html/rfc8446#section-6.2
"no_application_protocol: Sent by servers when a client
"application_layer_protocol_negotiation" extension advertises only
protocols that the server does not support (see [RFC7301])."
Sets crypto algorithm mapping for different platforms.
TLS Pre-Shared Key extension.
https://tools.ietf.org/html/rfc8446#section-6.2
"protocol_version: The protocol version the peer has attempted to
negotiate is recognized but not supported (see Appendix D)."
TLS Pre-Shared Key Exchange Modes extension.
The SecP256r1MLKEM768 hybrid group (RFC 10024): classical (EC) component
first in the client/server key shares and the secret combiner.
The SecP384r1MLKEM1024 hybrid group (RFC 10024): classical (EC) component
first in the client/server key shares and the secret combiner.
https://datatracker.ietf.org/doc/html/rfc8446#section-4.1.3
TLS server name extension: RFC 6066
https://tools.ietf.org/html/rfc6066#section-3
TLS Pre-Shared Key Extension, ServerHello variant.
The signature algorithm that implements one TLS signature scheme.
Creates the signature algorithm implementation for a given TLS signature scheme.
The TLS signature algorithms extension.
The TLS supported groups extension.
The TLS supported versions extension.
Notifies state changes in the TLS layer.
https://tools.ietf.org/html/rfc8446#section-6.2
"unexpected_message: An inappropriate message (e.g., the wrong
handshake message, premature Application Data, etc.) was received.
https://tools.ietf.org/html/rfc8446#section-6.2
"unsupported_extension: Sent by endpoints receiving any handshake
message containing an extension known to be prohibited for
inclusion in the given handshake message, or including any
extensions in a ServerHello or Certificate not first offered in
the corresponding ClientHello or CertificateRequest."
The X25519MLKEM768 hybrid group (RFC 10024): ML-KEM component first in
the client/server key shares and the secret combiner.
Implementation of the X25519 and X448 key exchange algorithms.